HOME       INTEGRATION ECOSYSTEM       AUTHENTICATORS       RESOURCES

US - Enrollment Service Incident

Incident Report for SafeNet Trusted Access

Resolved

The Cloud Provider has confirmed they have recovered services on their end. We will now close this incident.
Posted Jul 18, 2025 - 17:07 UTC

Update

The issue appear to have originated from our Cloud Services provider. While we continue to see service stability and reliability at this time, we will keep this incident open until we get confirmation that the issues on the provider's end have been fully resolved.
Posted Jul 18, 2025 - 16:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2025 - 15:53 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 18, 2025 - 15:50 UTC

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 15:48 UTC

Investigating

The SafeNet Trusted Access monitoring system has detected a problem with "Enrollment Service " for some customers.

New enrollment activities will be impeded during this time.

The Thales Incident Response Team is actively investigating this problem and will update this incident with additional information as it becomes available.
Posted Jul 18, 2025 - 15:34 UTC
This incident affected: US Service Zone (End User Services).