Get email notifications whenever SafeNet Trusted Access creates, updates or resolves an incident.
Get text message notifications whenever SafeNet Trusted Access creates or resolves an incident.
Get webhook notifications whenever SafeNet Trusted Access creates an incident, updates an incident, resolves an incident or changes a component status.
All testing has passed and services are running optimally from the primary site.
Posted Dec 06, 2025 - 17:59 UTC
Update
Services have been failed back the primary site. We are now conducting testing to ensure service continuity and reliability.
Posted Dec 06, 2025 - 17:46 UTC
Update
We will commence the fail-back to the primary site in 10 minutes
Posted Dec 06, 2025 - 17:21 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2025 - 14:34 UTC
Scheduled
Our testing has concluded and we have not detected any abnormalities within our services. We will begin fail-back at 17:30 UTC.
Posted Dec 06, 2025 - 14:33 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2025 - 14:24 UTC
Scheduled
All primary services have been verified as running as expected on the secondary site. Our testing continues and we will update prior to beginning the fail-back process.
Posted Dec 06, 2025 - 14:23 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2025 - 14:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 18, 2025 - 00:00 UTC
Scheduled
We want to ensure the utmost reliability and resilience of our STA systems to continue serving you effectively. To achieve this, we will be conducting a Disaster Recovery Test in the STA Classic region only on December 6, 2025
What does this mean for STA Classic region customers?
Taking this proactive step will minimize disruptions during the downtime of the STA Classic primary zone and facilitate a smooth transition to disaster recovery measures. We kindly ask you to prepare by reviewing and updating your configurations to ensure a smooth transition.