HOME       INTEGRATION ECOSYSTEM       AUTHENTICATORS       RESOURCES

EU Authentication & Console - Degradation

Incident Report for SafeNet Trusted Access

Postmortem

Posted Sep 04, 2025 - 18:55 UTC

Resolved

This incident has been resolved.
Posted Aug 24, 2025 - 04:52 UTC

Investigating

The Safenet Trusted Access monitoring system detected blips in the authentication and console usage for some customers on August 24th 2025 between 3:21 and 3:29 UTC.

The issue has been rectified and fixed by the Incident Response team.
Posted Aug 24, 2025 - 04:49 UTC
This incident affected: EU Service Zone (Authentication Services, Admin Consoles).