HOME       INTEGRATION ECOSYSTEM       AUTHENTICATORS       RESOURCES

All Regions - Degraded E-mail Delivery

Incident Report for SafeNet Trusted Access

Resolved

Our e-mail service provider has confirmed the issue is resolved on their end. We will now close this incident.
Posted Aug 22, 2025 - 17:25 UTC

Identified

Our e-mail service provider is experiencing an issue where a small subset of customers might see delayed email delivery. They have informed us that they are working with their upstream service provider to restore services.
Posted Aug 22, 2025 - 17:04 UTC
This incident affected: EU Service Zone (End User Services), US Service Zone (End User Services), and Classic Service Zone (End User Services).